Ir al contenido principal

Rangos con nombre en Excel

Nombrar rangos en Excel es una forma practica y facil de referirnos a una o varias celdas a través de una etiqueta con significado dentro del contexto de libro de trabajo de Excel. El siguiente extracto del articulo "Definición de rangos de celdas en excel" redactado por Gabriel Tomich para el periodico la Nación. Articulo completo. nos muestra algunas de sus utilidades practicas.

¿Para qué sirve concretamente tener rangos con nombres? Una de sus principales utilidades consiste en facilitar la selección del rango; es decir, evitar el proceso de cliquear la celda del vértice superior izquierdo y arrastrar el mouse hasta la del vértice inferior derecho. Esta tarea, aunque es fácil en conjuntos de celdas pequeños, resulta bastante pesada con rangos más extensos.
Al tener un nombre, el rango puede seleccionarse así: si aún sigue seleccionado, desmarque el rango Inicial con un clic en cualquier celda ajena a él. Posteriormente, corra el comando Edición/Ir a(o, directamente, ejecute el atajo de teclado Ctrl+I ) para abrir el cuadro de diálogo Ir a. Allí encontrará un listado con los nombres de todos los rangos generados (similar al del comandoDefinir). Luego, haga un clic en Inicial (nombre que se escribirá automáticamente en la caja de texto Referencia) y presione el botón Aceptar. De inmediato, la ventana se cierra y el rango A1:B2queda seleccionado.
Otro uso concreto es el ya mencionado de utilizar un rango como argumento de una función. Veamos un ejemplo simple utilizando Inicial.
Active la celda A4 o, en su defecto, cualquiera que esté vacía. Luego, ejecute el comandoInsertar/Función y, en la ventana correspondiente, busque en el listado Categoría de la función, las ocurrencias Usadas recientemente, Todas o Matemáticas y trigonométricas. Seleccione una de ellas y, en la lista Nombre de la función, marque Suma; una vez realizado esto, presione el botón Aceptar para pasar a la segunda ventana del asistente de funciones.
En ella encontrará activa la caja de texto Número1. No haga caso del rango por defecto que ésta pueda contener y corra la instrucción Insertar/Nombre. El submenú de ésta sólo tendrá habilitado el ítem Pegar, precisamente el que hace falta. Haga un clic en él para abrir el correspondiente cuadro de diálogo, marque el único nombre que tenemos, Inicial, y apriete Aceptar. De inmediato, el cuadro de diálogo se cierra y en la caja Número1 queda escrito Inicial. Pulse Aceptar y, automáticamente, en A4 obtendrá el resultado de la suma de los números que contienen las 4 celdas del rango.
Un ejemplo de como se puede mejorar la comprensión de una hoja de Excel usando nombres para los rangos
TIPO DE EJEMPLOEJEMPLO SIN NOMBREEJEMPLO CON NOMBRE
Referencia=SUMA(C20:C30)=SUMA(VentasPrimerTrimestre)
Constante=PRODUCTO(A5,8.3)=PRODUCTO(Precio,ImpuestoVentasEstatal)
Fórmula=SUMA(BUSCARV(A1;B1:F20;5;FALSE); -G5)=SUMA(Nivel_Inventario;-Cant_Pedidos)
TablaC4:G36=PrincipalesVentas06
 Fuente de la tabla: Microsoft Office

Comentarios

Entradas más populares de este blog

Ejercicio Condicionales usando Macros en Excel

La toma de decisiones es determinante en la secuencia de ejecución de una macro. Las herramientas que proporciona VBA para la toma de decisiones descansan en los condicionales. Un ejemplo de estructuras condicionales en Excel es la función "SI", la cual permite hacer una prueba lógica y tomar generar dos resultados posibles dependiendo si la prueba lógica es verdadera o falsa. "SI su estatura en metros es superior a 1.5 mts, puede ingresar a la montaña rusa, de lo contrario NO". En la afirmación anterior solo aquellos niños con una estatura superior a 1.5 tendrán acceso al juego mecánico, los demás niños simplemente estarán excluidos del juego hasta que cumplan el requisito de forma imperativa.
El lenguaje de macros permite 3 estructuras condicionales distintas:
a) IIF(prueba_lógica, verdadero, falso). Su resultado obligatoriamente debe asignarse a una variable
variable = IFF(3>1, "Verdadero", "Falso"). El tipo de variable puede ser numero, …

Variables y Tipos de datos - Macros en Excel

Las variables son útilies en la creación de Macros. Son de nuestro especial interés cuando deseamos desarrollar formulas personalizadas (User Defined Formulas). Para introducirnos en el tema de la creación de formulas, necesitamos reconocer los tipos de datos existentes y tener la capacidad de utilizarlos. A continuación se presenta una tabla con los tipos de datos y la capacidad de almacenamiento según el tipo.


Cada de uno de estos tipos de datos deben usarse en concordancia con el objetivo de la macro. El siguiente ejercicio muestra el uso de variables tipo entero (integer):

Entrar una cantidad que representa el precio de algo por el teclado con la instrucción InputBox y
guardarlo en la celda A1 de la hoja activa. Si el valor entrado desde el teclado (y guardado en A1) es superior a 1000, pedir descuento con otro InputBox y guardarlo en la casilla A2 de la hoja activa.
Calcular en A3, el precio de A1 menos el descuento de A2.

Sub variables1()
Dim Precio As Integer     'Variables ti…